跳转到内容
主菜单
主菜单
移至侧栏
隐藏
规范/协议
协议
算法
JVM
多线程/并发
存储
AI
深度学习
工具箱
最近更改
文章分类
全部文章
WHY42
搜索
搜索
外观
登录
个人工具
登录
欢迎来到Riguz的小站!这是一个私人wiki,用来记录一些我的笔记。
查看“︁CentOS:svn服务器安装”︁的源代码
页面
讨论
大陆简体
阅读
查看源代码
查看历史
工具
工具
移至侧栏
隐藏
操作
阅读
查看源代码
查看历史
常规
链入页面
相关更改
页面信息
外观
移至侧栏
隐藏
←
CentOS:svn服务器安装
因为以下原因,您没有权限编辑该页面:
您请求的操作仅限属于该用户组的用户执行:
用户
您可以查看和复制此页面的源代码。
==Svn及相关模块的安装== <syntaxhighlight lang="bash"> yum install subversion mod_dav_svn mod_authz_ldap </syntaxhighlight> 初始化svn库 <syntaxhighlight lang="bash"> mkdir /home/svn svnadmin create /home/svn/repos </syntaxhighlight> 设置Apache的访问权限 <syntaxhighlight lang="bash"> chown -R apache.apache repos </syntaxhighlight> 然后修改配置文件 <syntaxhighlight lang="bash"> vim /etc/httpd/conf.d/subversion.conf </syntaxhighlight> 主要修改内容如下: <pre> <Location /svn> DAV svn SVNParentPath /home/svn AuthType Basic AuthBasicProvider ldap AuthzLDAPAuthoritative off AuthLDAPURL "ldap://127.0.0.1:389/dc=brilliance,dc=com?uid?sub?(objectClass=*)" AuthName "Nice to meet you,but you know..." AuthzSVNAccessFile /home/svn/authz.conf Require valid-user </Location> </pre> Svn地址: <pre> http://192.168.1.9/svn/repos </pre> 重启Apache 即可 <syntaxhighlight lang="bash"> service httpd restart </syntaxhighlight> 附注: 若svn提交失败,提示Permission denied,是因为svnadmin创建库时是root用户,导致apache无法访问。解决方式: <syntaxhighlight lang="bash"> chown –R apache.apache /home/svn/documents chmod 775 /home/svn/documents </syntaxhighlight> [[Category:Linux/Unix]]
返回
CentOS:svn服务器安装
。
搜索
搜索
查看“︁CentOS:svn服务器安装”︁的源代码
添加话题